Need assistance setting up Mixxx on Linux with Focusrite

Fixxx your Mixxx

Moderator: garth

Need assistance setting up Mixxx on Linux with Focusrite

Postby mjstone323 » Thu Jan 23, 2020 9:07 pm

Hello! I am a brand new Mixxx user!

I have been trying to set up Mixxx to broadcast music and voice, on the latest version of Ubuntu. I am running my mic through a Focusrite Scarlett 2i4. I have been able to broadcast music through my Shoutcast server, but for some reason I can't broadcast my voice.
The mic output is getting into Mixxx - the graphic gain monitor is moving upward with my voice, and there is appropriate ducking, but my voice isn't broadcasted along with the music.

These are the messages I'm receiving when I start Mixxx:

One or more MixxxControls specified in the outputs section of the loaded preset were invalid.
Some LEDs or other feedback may not work correctly.

* Check to see that the MixxxControl names are spelled correctly in the mapping file (.xml)
* Make sure the MixxxControls in question actually exist. Visit this wiki page for a complete list: http://mixxx.org/wiki/doku.php/mixxxcontrols

MIDI output message 0x90 0x46 has invalid MixxxControl [Channel2], flanger
MIDI output message 0x90 0x32 has invalid MixxxControl [Channel1], flanger

Let me know if there's any more info needed to fix this issue.
mjstone323
 
Posts: 3
Joined: Thu Jan 23, 2020 8:13 pm

Re: Need assistance setting up Mixxx on Linux with Focusrite

Postby JosepMa » Thu Jan 23, 2020 9:22 pm

About the microphone: You might try to change the microphone monitoring setting in Preferences.

About the other errors, they are unrelated to the microphone. They mean that the mapping that you have for the controller is made for Mixxx previous to 2.0.
On Mixxx 2.0, the flanger control was deprecated and now there are separated effect controls and a filter control.
You could try modifying the controller mapping on the preferences, using the "output" tab of the controller configuration, so that, at least, you don't get the errors.
JosepMa
 
Posts: 865
Joined: Sat Oct 10, 2015 7:02 pm

Re: Need assistance setting up Mixxx on Linux with Focusrite

Postby mjstone323 » Thu Jan 23, 2020 9:31 pm

JosepMa wrote:About the microphone: You might try to change the microphone monitoring setting in Preferences.

About the other errors, they are unrelated to the microphone. They mean that the mapping that you have for the controller is made for Mixxx previous to 2.0.
On Mixxx 2.0, the flanger control was deprecated and now there are separated effect controls and a filter control.
You could try modifying the controller mapping on the preferences, using the "output" tab of the controller configuration, so that, at least, you don't get the errors.


Thanks for your reply! I have been fiddling with the Sound Hardware settings and alternately fixing and breaking the output XD Is that what you mean by "microphone monitoring setting"?

I appreciate your suggestions about the error messages. It's helpful to know they're not related to the mic problems I'm having. My priority is to get that mic output broadcast with the music.
mjstone323
 
Posts: 3
Joined: Thu Jan 23, 2020 8:13 pm

Re: Need assistance setting up Mixxx on Linux with Focusrite

Postby mjstone323 » Thu Jan 23, 2020 9:43 pm

Okay - I now see what you mean by "microphone monitoring settings". Unfortunately, this part is greyed out for me. it is on Direct Monitoring.
mjstone323
 
Posts: 3
Joined: Thu Jan 23, 2020 8:13 pm

Re: Need assistance setting up Mixxx on Linux with Focusrite

Postby Be. » Fri Jan 24, 2020 4:39 am

You need to configure a Microphone input for the Microphone monitor mode option to become available. It should be set to direct monitor. Refer to the manual for details.
Mixxx is free because it's yours!

I heard FLAC and I haven't gone back.
Protect your hearing with earplugs!

Hear my mixes
User avatar
Be.
Mixxx Developer
 
Posts: 2557
Joined: Tue Jan 06, 2015 1:00 am
Location: Chicago, USA


Return to Troubleshooting & FAQ

Who is online

Users browsing this forum: Google [Bot] and 52 guests