Howto disable Keyboard Shortcuts?

Customized keyboard mappings that suit different uses

Moderators: garth, User Customization Moderators

Howto disable Keyboard Shortcuts?

Postby dogo77 » Fri Mar 25, 2011 8:57 am

Hi,

yesterday i ran into serious trouble while having 50 people dancing. I often use the search in the left pane and hammered my keys not noticing the serch field didn't have the focus. one of the keys i pressed was »D« … m-)
Should not happen again, so is there a switch for disabling the shortcuts and using the keybord _just for searching_?
tia
archlinux x86_64 · mixxx1.11 · american audio vms4
User avatar
dogo77
 
Posts: 46
Joined: Tue Oct 19, 2010 5:29 pm
Location: dresden, sn

Re: Howto disable Keyboard Shortcuts?

Postby rryan » Fri Mar 25, 2011 5:56 pm

Hey dogo77,

Sorry about that :-/ I think we have a bug open for that feature already: https://bugs.launchpad.net/mixxx/+bug/685815

As a workaround, you can delete all the shortcuts in your Standard.kbd.cfg file. What OS are you on? I can tell you where that file is if you can't find it.

Cheers,
RJ Ryan
The Mixxx Manual, Wiki and FAQ are the best place to start for documentation and support.
Please report any bugs you find to our Bug Tracker.
rryan
Mixxx Developer
 
Posts: 1335
Joined: Thu Mar 26, 2009 12:14 am
Location: California

Re: Howto disable Keyboard Shortcuts?

Postby dogo77 » Fri Mar 25, 2011 10:35 pm

rryan wrote:Hey dogo77,

Sorry about that :-/ I think we have a bug open for that feature already: https://bugs.launchpad.net/mixxx/+bug/685815

Well, shit happens. :-)

rryan wrote:As a workaround, you can delete all the shortcuts in your Standard.kbd.cfg file. What OS are you on? I can tell you where that file is if you can't find it.

I did that now in /usr/share/mixxx/keyboard , so what's my OS? Ok, just kidding, mixxx 1.9 is running on archlinux x86_64 here.
Thanks for your help.

vg
archlinux x86_64 · mixxx1.11 · american audio vms4
User avatar
dogo77
 
Posts: 46
Joined: Tue Oct 19, 2010 5:29 pm
Location: dresden, sn

Re: Howto disable Keyboard Shortcuts?

Postby Korin » Mon Jul 04, 2011 3:51 pm

I second this as a wishlist feature. It has happened a few times, thinking my partner and I had selected the search button, before searching for something that ended up stopping the song mid-clubnight. Everybody gets one ;)
Korin
 
Posts: 38
Joined: Mon Nov 16, 2009 3:02 pm
Location: Glasgow

Re: Howto disable Keyboard Shortcuts?

Postby MelGrubb » Thu Oct 20, 2011 3:54 pm

I'd like to see an option to disable keyboard shortcuts when a contoller is present.

A more flexible option would be to designate a secondary keyboard mapping file to use when a controller is present. This way, you could still have SOME of the keyboard shortcuts if you need them. Think of someone with a Numark DJ2Go. It's super-portable, but pretty low on the number of controls available. I would want to leave some of the keyboard controls active in that case. For someone with a more "robust" controller, perhaps turning off all the keyboard shortcuts would make more sense. I think this is the easiest way to satisfy everyone.

Now, if you wanted to get super-fancy, you could associate keyboard mappings with individual controller mappings, or even combine the two concepts together in the same file. This would only be useful to people who use more than one controller on a regular basis (i.e. different controllers at different clubs), and I honestly don't think that's a high-percentage use case. I see it being more useful to have mixxx automatically switch from the "None" controller setup to the "Whatever" controller setup automatically, as it does now.
MelGrubb
 
Posts: 141
Joined: Tue Apr 27, 2010 12:00 pm


Return to Keyboard mappings

Who is online

Users browsing this forum: No registered users and 1 guest