Spartan - Skin for Mixxx 1.10 & 1.9

New or modified Mixxx skins

Moderators: garth, User Customization Moderators

Re: Spartan - Skin for Mixxx 1.9

Postby jus » Wed Nov 09, 2011 4:49 am

FYI an updated version is in the works, but please keep the ideas coming.
The Mixxx Manual, Wiki and FAQ are the best place to start for documentation and support.
Please report any bugs you find to our Bug Tracker.

Find out how to contribute to Mixxx development.
User avatar
jus
Mixxx Artist
 
Posts: 1009
Joined: Tue Jun 16, 2009 5:52 pm
Location: Berlin

Re: Spartan - Skin for Mixxx 1.9

Postby Irwin Cespedes » Sun Jan 22, 2012 3:17 am

Jus, I was trying to use the Spartan Skin in the new Mixxx 1.10. However, when I load the skin I have a SegFault. Take a look:

Code: Select all
Debug: [Main]: Mixxx 1.10.0 "(built on: Dec 25 2011 @ 05:27:51; flags: hifieq mad midiscript optimize=9 qdebug shoutcast verbose vinylcontrol)" is starting...
Debug: [Main]: Qt version is: 4.7.4
Debug: [Main]: Configuration file is at the current version 1.10.0
Debug: [Main]: Loading translations for locale "en_US" from translations folder "/usr/share/mixxx/translations/" : fail
Debug: [Main]: Found folder 'Mixxx' within default OS music directory
Debug: [Main]: Could not create folder 'Recordings' within 'Mixxx'
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Channel1]" , "vinylcontrol_mode" )
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Channel2]" , "vinylcontrol_mode" )
Debug: [Main]: JACK client name set
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround71
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
Debug: [Main]: Available QtSQL drivers: ("QSQLITE", "QMYSQL3", "QMYSQL")
Debug: [Main]: src/library/trackcollection.cpp DB status: true
Debug: [Main]: SchemaManager::upgradeToSchemaVersion already at version 13
Debug: [Main]: TrackDAO::initialize QThread(0x987c800, name = "Main") "qt_sql_default_connection"
Debug: [Main]: CrateDAO::initialize()
Debug: [Main]: CueDAO::initialize QThread(0x987c800, name = "Main") "qt_sql_default_connection"
Debug: [Main]: Promo dir: "/usr/share/mixxx//promo/1.8.0/index.html"
Debug: [Main]: Traktor Library Location=[ "/home/irwin/collection.nml" ]
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Flanger]" , "lfoDepth" )
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Flanger]" , "lfoDelay" )
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Flanger]" , "lfoPeriod" )
Debug: [Main]: CachingReader using 4980736 bytes.
Debug: [Main]: CachingReader using 4980736 bytes.
Debug: [Main]: CachingReader using 4980736 bytes.
Debug: [Main]: CachingReader using 4980736 bytes.
Debug: [Main]: CachingReader using 4980736 bytes.
Debug: [Main]: CachingReader using 4980736 bytes.
Debug: [Main]: Constructed LibraryScanner
Debug: [Main]: iTunes Album Art path is: ""
Debug: [Main]: MidiDeviceManager::getDeviceList
Debug: [Main]: Scanning PortMIDI devices:
Debug: [Main]:  Found output device # 0 Midi Through Port-0
Debug: [Main]:  Found output device # 2 C-Media CMI8738 MIDI
Debug: [Main]:  Found output device # 4 OPL3 FM Port
Debug: [Main]:  Found input device # 1 Midi Through Port-0
Debug: [Main]:     Linking to output device # 0 "Midi Through Port-0"
Debug: [Main]: Starting script engine with output device ""
Debug: [MidiScriptEngine 1]: MIDI Device in script engine is: ""
Debug: [Main]:  Found input device # 3 C-Media CMI8738 MIDI
Debug: [Main]:     Linking to output device # 2 "C-Media CMI8738 MIDI"
Debug: [Main]: Starting script engine with output device ""
Debug: [MidiScriptEngine 2]: MIDI Device in script engine is: ""
Debug: [Main]: MidiDeviceManager: Setting up devices
Debug: [Main]: PortMIDI device "1. Midi Through Port-0" already closed
Debug: [Main]: MidiMapping: Loading MIDI preset from "/home/irwin/.mixxx/midi/Midi_Through_Port-0.midi.xml"
Debug: [Main]: MidiOutputMappingTableModel::removeRows()
Debug: [Main]: "Midi Through Port-0"  settings found
Debug: [MidiScriptEngine 1]: MidiScriptEngine: Loading & evaluating all MIDI script code
Debug: [MidiScriptEngine 1]: MidiScriptEngine: Loading "/usr/share/mixxx/midi/midi-mappings-scripts.js"
Debug: [MidiScriptEngine 1]: MidiScriptEngine: Loading "/usr/share/mixxx/midi/Pioneer-CDJ-2000-scripts.js"
Debug: [Main]: MidiMapping: Input parsed!
Debug: [Main]: MidiMapping: Output parsed!
Debug: [Main]: PortMIDI device "3. C-Media CMI8738 MIDI" already closed
Debug: [Main]: MidiMapping: Loading MIDI preset from "/home/irwin/.mixxx/midi/C-Media_CMI8738_MIDI.midi.xml"
Debug: [Main]: MidiOutputMappingTableModel::removeRows()
Debug: [Main]: "C-Media CMI8738 MIDI"  settings found
Debug: [MidiScriptEngine 2]: MidiScriptEngine: Loading & evaluating all MIDI script code
Debug: [MidiScriptEngine 2]: MidiScriptEngine: Loading "/usr/share/mixxx/midi/midi-mappings-scripts.js"
Debug: [Main]: MidiMapping: Input parsed!
Debug: [Main]: MidiMapping: Output parsed!
Debug: [Main]: Promo dir: "/usr/share/mixxx//promo/1.8.0/index.html"
Debug: [Main]: loadSettings: 1 0 "SlowFade"
Debug: [Main]: slotApply crossfader: 1 "SlowFade"
Debug: [Main]: BpmSchemes::readXML "/home/irwin/.mixxx/mixxxbpmscheme.xml"
Debug: [Main]: MidiDeviceManager::getDeviceList
Debug: [Main]: MidiDeviceManager::getDeviceList
Debug: [Main]: MidiDeviceManager::getDeviceList
Debug: [Main]: SoundManager::setupDevices()
Debug: [Main]: SoundDevicePortAudio::open() "1, C-Media CMI8738: C-Media PCI 2nd DAC (hw:0,1)"
Debug: [Main]: framesPerBuffer: 256
Debug: [Main]: Requested sample rate:  44100 Hz, latency: 5.80499 ms
Debug: [Main]: Output channels: 2 | Input channels: 0
Debug: [Main]: Opening stream with id 1
Debug: [Main]: Opened PortAudio stream successfully... starting
Debug: [Main]: Dynamically loaded PortAudio library
Debug: [Main]: PortAudio: Started stream successfully
Debug: [Main]:    Actual sample rate:  44100 Hz, latency: 11.61 ms
Debug: [Main]: Using "C-Media CMI8738: C-Media PCI 2nd DAC (hw:0,1)" as output sound device clock reference
Debug: [Main]: 1 output sound devices opened
Debug: [Main]: 0 input  sound devices opened
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Samplers]" , "show_samplers" )
Warning: [Main]: Requested control does not exist: "[Samplers],show_samplers" . Creating it.
Debug: [Main]: Making property binder for "visible"
Warning: [Main]: Object::connect: No such slot QGroupBox::setProperty(const char*, const QVariant&) in src/skin/propertybinder.cpp:13
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Sampler1]" , "hotcue_38_position" )
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Sampler2]" , "hotcue_38_position" )
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Sampler3]" , "hotcue_38_position" )
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Sampler4]" , "hotcue_38_position" )
Debug: [Main]: BaseTrackCache(0x9a44000) updateIndexWithQuery took 50 ms
Debug: [Main]: PlaylistTableModel(0x9f62390) select() took 52 ms
Debug: [Main]: PrepareLibraryTableModel(0xa18f0e0) select() took 22 ms
Debug: [Main]: PrepareLibraryTableModel(0xa18f0e0) select() took 22 ms
Debug: [Main]: PrepareLibraryTableModel(0xa18f0e0) select() took 22 ms
Debug: [Main]: DlgPrepare(0xa16d6f8, name = "DlgPrepare") analysisActive false
Debug: [Main]: MixxxLibraryFeature::activate()
Debug: [Main]: LibraryTableModel(0x9a44b10) select() took 33 ms
Debug: [Main]: WSearchLineEdit::restoreSearch( "" )
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Vinylcontrol]" , "show_vinylcontrol" )
Warning: [Main]: Requested control does not exist: "[Vinylcontrol],show_vinylcontrol" . Creating it.
Debug: [Main]: Making property binder for "visible"
Warning: [Main]: Object::connect: No such slot QGroupBox::setProperty(const char*, const QVariant&) in src/skin/propertybinder.cpp:13
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Microphone]" , "show_microphone" )
Warning: [Main]: Requested control does not exist: "[Microphone],show_microphone" . Creating it.
Debug: [Main]: Making property binder for "visible"
Warning: [Main]: Object::connect: No such slot QGroupBox::setProperty(const char*, const QVariant&) in src/skin/propertybinder.cpp:13
Warning: [Main]: QGLContext::makeCurrent(): Cannot make invalid context current.
Debug: [Main]: createWaveformViewer()
Debug: [Main]: WaveformViewerFactory :: Creating new visual waveform
Debug: [Main]: WaveformViewerFactory :: Making new GL context.
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Spinny1]" , "show_spinny" )
Warning: [Main]: Requested control does not exist: "[Spinny1],show_spinny" . Creating it.
Debug: [Main]: Making property binder for "visible"
Warning: [Main]: Object::connect: No such slot QGroupBox::setProperty(const char*, const QVariant&) in src/skin/propertybinder.cpp:13
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Channel1]" , "hotcue_38_position" )
Debug: [Main]: createWaveformViewer()
Debug: [Main]: WaveformViewerFactory :: Creating new visual waveform
Debug: [Main]: WaveformViewerFactory :: Sharing existing GL context.
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Spinny2]" , "show_spinny" )
Warning: [Main]: Requested control does not exist: "[Spinny2],show_spinny" . Creating it.
Debug: [Main]: Making property binder for "visible"
Warning: [Main]: Object::connect: No such slot QGroupBox::setProperty(const char*, const QVariant&) in src/skin/propertybinder.cpp:13
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Channel2]" , "hotcue_38_position" )
Debug: [Main]: Displaying mixxx
Debug: [Main]: Running Mixxx
Debug: [Main]: guess the size of the window decoration
Debug: [Main]: Now in Rebootmixxview...
Debug: [Main]: PlaylistTableModel(0x9e60450) select() took 0 ms
Debug: [Main]: PrepareLibraryTableModel(0x9ca4db0) select() took 22 ms
Debug: [Main]: PrepareLibraryTableModel(0x9ca4db0) select() took 22 ms
Debug: [Main]: PrepareLibraryTableModel(0x9ca4db0) select() took 21 ms
Debug: [Main]: DlgPrepare(0xa16d6f8, name = "DlgPrepare") analysisActive false
Debug: [Main]: DlgPrepare(0x9d77df0, name = "DlgPrepare") analysisActive false
Debug: [Main]: MixxxLibraryFeature::activate()
Debug: [Main]: LibraryTableModel(0x9a44b10) select() took 34 ms
Debug: [Main]: LibraryTableModel(0x9a44b10) select() took 34 ms
Debug: [Main]: WSearchLineEdit::restoreSearch( "" )
Debug: [Main]: WSearchLineEdit::restoreSearch( "" )
Debug: [Main]: createWaveformViewer()
Debug: [Main]: WaveformViewerFactory :: Creating new visual waveform
Debug: [Main]: WaveformViewerFactory :: Sharing existing GL context.
Debug: [Main]: WaveformRenderMarkRange(0xaf453a20) ~WaveformRenderMarkRange()
Debug: [Main]: WaveformRenderMark(0xaf454568) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf461938) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf465df8) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf460968) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf461810) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf45d4b8) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf4615b0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf45e270) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5cde28) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf45f020) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5ce108) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf45ace0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5d5b98) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5da1d0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5d9e80) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5de040) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5ddd00) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5e27f0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5e1de8) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5e4748) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5e49e0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5e83d0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5eca40) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5ec600) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5ee970) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5eeb78) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5f2b68) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf45ac58) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5f72e0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5f6d38) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5fa8a8) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5fecc0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa5feb48) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa600ca8) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa603010) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa607720) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa609a08) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa6090b0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xa60b850) ~WaveformRenderMark()
Debug: [Main]: createWaveformViewer()
Debug: [Main]: WaveformViewerFactory :: Creating new visual waveform
Debug: [Main]: WaveformViewerFactory :: Sharing existing GL context.
Debug: [Main]: WaveformRenderMarkRange(0xaf483b20) ~WaveformRenderMarkRange()
Debug: [Main]: WaveformRenderMark(0xaf484688) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf487650) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf4888a0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf497a80) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf497d60) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf4985d0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf498ce0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf4993b8) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaca1ea8) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf4720a8) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaca5570) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf4728f0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacaaf48) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacace70) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacaee58) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacb1178) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacb0e40) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacb51f8) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacb7320) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacbb860) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacbb778) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacbd950) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacc01b0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacc3f90) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacc4420) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacc5d58) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacc7e10) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaf472868) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacce398) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacd0248) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xaccfe28) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacd3ce8) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacd4000) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacd84b8) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacd7fc0) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacda438) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacdc598) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xacde730) ~WaveformRenderMark()
Debug: [Main]: WaveformRenderMark(0xace08c8) ~WaveformRenderMark()
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Channel1]" , "hotcue_38_position" )
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Channel2]" , "hotcue_38_position" )
Debug: [Main]: WPixmapStore couldn't load: "/usr/share/mixxx/skins/Spartan1366x768-WXGA v0.9b/slider_volume1.png" false
Debug: [Main]: WSliderComposed: Error loading slider pixmap: "/usr/share/mixxx/skins/Spartan1366x768-WXGA v0.9b/slider_volume1.png"
Debug: [Main]: WPixmapStore couldn't load: "/usr/share/mixxx/skins/Spartan1366x768-WXGA v0.9b/knob_volume1.png" false
Debug: [Main]: WSliderComposed: Error loading handle pixmap: "/usr/share/mixxx/skins/Spartan1366x768-WXGA v0.9b/knob_volume1.png"
Segmentation fault


Dunno whether it's the skin, or that something change in the way Mixxx loads skins.

Thanks!
I am also known as altiplΛne, this is my music

¡Pura Vida! Image
User avatar
Irwin Cespedes
 
Posts: 170
Joined: Mon Feb 01, 2010 8:59 pm
Location: Puntarenas, Costa Rica

Re: Spartan - Skin for Mixxx 1.9

Postby jus » Mon Jan 23, 2012 4:34 am

Obviously Mixxx 1.10 does not tolerate errors in the skin like 1.9 did.
Basically the skin tries to load elements which are not available.
Working on a fix for Spartan, nevertheless Mixxx should not crash in such case.
I`ll file a separate bug for this.
The Mixxx Manual, Wiki and FAQ are the best place to start for documentation and support.
Please report any bugs you find to our Bug Tracker.

Find out how to contribute to Mixxx development.
User avatar
jus
Mixxx Artist
 
Posts: 1009
Joined: Tue Jun 16, 2009 5:52 pm
Location: Berlin

Re: Spartan - Skin for Mixxx 1.9

Postby rryan » Mon Jan 23, 2012 4:51 pm

Yes that's definitely a bug, please file :)
The Mixxx Manual, Wiki and FAQ are the best place to start for documentation and support.
Please report any bugs you find to our Bug Tracker.
rryan
Mixxx Developer
 
Posts: 1335
Joined: Thu Mar 26, 2009 12:14 am
Location: California

Re: Spartan - Skin for Mixxx 1.9

Postby jus » Mon Jan 23, 2012 8:08 pm

I just added the Spartan1280x800-WXGA v1.10.01 skin for Mixxx 1.10 to the first page of this thread.
This is mainly a bugfix release of the skin, there are not much new features visible (see changelog).

Please test and report. If it runs fine, i´ll add the 1366x768-WXGA variant as well.
The Mixxx Manual, Wiki and FAQ are the best place to start for documentation and support.
Please report any bugs you find to our Bug Tracker.

Find out how to contribute to Mixxx development.
User avatar
jus
Mixxx Artist
 
Posts: 1009
Joined: Tue Jun 16, 2009 5:52 pm
Location: Berlin

Re: Spartan - Skin for Mixxx 1.9

Postby Pegasus » Mon Jan 23, 2012 8:33 pm

Cool, I'll test this out since I like to do as much as possible from my controllers.
"D.J. Pegasus"
Mixxx Developer - Controller Specialist
Mixxx Windows package maintainer
User avatar
Pegasus
Mixxx Developer
 
Posts: 1712
Joined: Thu Jan 29, 2009 7:48 pm
Location: Las Vegas, NV, USA

Re: Spartan - Skin for Mixxx 1.9

Postby Irwin Cespedes » Tue Jan 24, 2012 6:00 pm

Way to go Jus! However, when I go Fullscreen, it get stuck in the middle of the screen, as you see here. This is on Ubuntu 12.04, using Gnome 3

Spartan 1.10.jpg
Mixxx 1.10 w/ Spartan Skin FullScreen
Spartan 1.10.jpg (179.85 KiB) Viewed 10573 times


Oh man, I'm such a pain in the neck :lol:
I am also known as altiplΛne, this is my music

¡Pura Vida! Image
User avatar
Irwin Cespedes
 
Posts: 170
Joined: Mon Feb 01, 2010 8:59 pm
Location: Puntarenas, Costa Rica

Re: Spartan - Skin for Mixxx 1.10 & 1.9

Postby bestdani » Tue Apr 10, 2012 5:16 pm

Hello alltogether,
I made a tiny modification of the Spartan Skin for Mixxx 1.10. I changed the sizes and positions for my 1366x768 px screen and I also removed the big waveform view for an even larger library view. Because maybe someone could like this modification, I'll share it here.

I also found a bug while testing. In the orginal v1.10.01 skin.xml line 622 should be:
Code: Select all
<ConfigKey>[Channel2],playposition</ConfigKey>

instead of "[Channel1]" because strange time position behaviour is the result. ;-)

The "1366x768-WXGA v1.10.01 no waveform edit" running on win7 pro x64:
Image
Attachments
Spartan1366x768-WXGA v1.10.01 no waveform edit.zip
(72.6 KiB) Downloaded 532 times
bestdani
 
Posts: 66
Joined: Fri Jul 02, 2010 9:38 am
Location: Germany

Re: Spartan - Skin for Mixxx 1.11

Postby bestdani » Mon May 13, 2013 8:20 pm

Hi there!
I've just updated the original 1280x800 and my no waveform edit for mixxx 1.11.0
These are just minor changes affecting the library which has been shown wrong in 1.11 with the old code and the waveform overview that did not show the markers in 1.11.

Enjoy!

New Screenshot in Mixxx 1.11.0 running on ubuntu studio
Image
Attachments
Spartan1366x768-WXGA v1.11.00 no waveform edit.zip
My 1366x768 no waveform edit
(81.35 KiB) Downloaded 437 times
Spartan1280x800-WXGA v1.11.01.zip
Original Spartan updated
(70.55 KiB) Downloaded 439 times
bestdani
 
Posts: 66
Joined: Fri Jul 02, 2010 9:38 am
Location: Germany

Re: Spartan - Skin for Mixxx 1.10 & 1.9

Postby Irwin Cespedes » Tue May 14, 2013 12:23 am

Nevermind, I have tweaked bestdani tweak and finally we have Spartan skin for Mixxx 1.11 with full waveforms!!!

Screenshot.png
Two Screen Mixxx
Screenshot.png (831.41 KiB) Viewed 9364 times


As you may see in my double screened screenshot, this is a corrected version for Spartan for 1366x768 screens. I will check it on y laptop, although, if in this screen works well, the same would be on any laptop.

Here you have the file, thanks Jus for the skin, and to Bestdani who managed to fit it for 1.11.
Spartan1366x768-WXGA v1.11.01 by irwincespedes.tar.gz
Da' Skin
(120 KiB) Downloaded 497 times
I am also known as altiplΛne, this is my music

¡Pura Vida! Image
User avatar
Irwin Cespedes
 
Posts: 170
Joined: Mon Feb 01, 2010 8:59 pm
Location: Puntarenas, Costa Rica

PreviousNext

Return to Skins

Who is online

Users browsing this forum: No registered users and 2 guests