Vinyl control problems with NI Audio4 DJ

Fixxx your Mixxx

Moderator: garth

Re: Vinyl control problems with NI Audio4 DJ

Postby Dronem » Tue May 10, 2016 6:50 pm

Thanks for your reply. But i already have installed ubuntu studio. Like i wrote before, it nearly works - one channel works with vinyl control.... but i was already thinking about getting me a audio6... what problems did you have with ubuntu 16.06?

greets
Dronem
 
Posts: 11
Joined: Fri Feb 19, 2016 4:42 pm

Re: Vinyl control problems with NI Audio4 DJ

Postby Be. » Tue May 10, 2016 9:11 pm

D=p+cer wrote:I just read all these messages, I noticed that your card is not in the supported hardware list
http://www.mixxx.org/wiki/doku.php/hard ... patibility


That list is not exhaustive and does not show sound cards that have been discontinued by their manufacturer, which the Audio 4 DJ was when the Traktor Scratch A6 was introduced.

D=p+cer wrote:Still weird, because the other NI cards all work.


Yes, the older ones have ALSA drivers. The newer ones like the Traktor Audio 2 Mk2 are USB class compliant and don't need any special driver.

D=p+cer wrote:I had it running on Ubuntu 15.10, but since the new release (16.04) it's not running very smoothly, it workes, but Mixxx itself becomes very very slow.
So I installed Ubuntu Studio 16.04, but had the same problem.

The thing is, Ubuntu Studio maybe has all the correct "drivers" and settings for your card pre-installed.
I'm going to install Studio 14.04 for now, maybe that will work for you as well.

If not I'm afraid someone will have to make a "driver" for it. It should be possible.

Good luck


If the sound card works at all with Mixxx, the sound card driver is most likely working as it should.
Mixxx is free because it's yours!

I heard FLAC and I haven't gone back.
Protect your hearing with earplugs!

Hear my mixes
User avatar
Be.
Mixxx Developer
 
Posts: 2573
Joined: Tue Jan 06, 2015 1:00 am
Location: Chicago, USA

Re: Vinyl control problems with NI Audio4 DJ

Postby nm2107 » Tue Jun 23, 2020 8:57 am

Indeed configuring the `~/.asoundrc` file does the trick :


Code: Select all
# ~/.asoundrc
pcm.Audio4DJChannelA {type plug; slave.pcm "hw:Audio4DJ,0,0";}
pcm.Audio4DJChannelB {type plug; slave.pcm "hw:Audio4DJ,0,1";}



then, use `Audio4DJChannelA` and `Audio4DJChannelB` (sub-channels 1-2) on the input and output panels of mixxx to use VCS for your A and B decks.

No need to differentiate input and output in the `~/.asoundrc` config file as alsa is already differentiating it by design (i.e. `aplay` VS `arecord` commands).

See `$ aplay -l` and `$ arecord -l` commands which are listing devices for playback (i.e. output), and devices for recording (i.e. input).

With this config, no need to specify the `PA_ALSA_PLUGHW=1` env var.

Also, make sure to configure the Audio4DJ input mode properly (phono or line or timecode, cf https://ywwg.com/wordpress/archives/772 )
nm2107
 
Posts: 4
Joined: Mon May 04, 2020 12:05 am

Previous

Return to Troubleshooting & FAQ

Who is online

Users browsing this forum: Google [Bot] and 22 guests

cron