1.12.0 Alpha Win (XP,Vista,7,8) / Mac / Linux Testers Needed

General Mixxx discussion.... discuss

Moderator: garth

Re: 1.12.0 Alpha Win (XP,Vista,7,8) / Mac / Linux Testers Ne

Postby Krosian » Sun Mar 01, 2015 7:07 pm

rryan wrote:[

Does the 14.04 deb fail to install?


Yes, it's good :) Thanks a lot !

I have made some tests, i see very good improvements :)

I think I see some "bugs" :
- I use a numark mixtrack pro controller and the buttons for effects doesn't work
- when i do a loop, the button cue point (1,2,3) doesn't permit to take out the loop to jump on a the cue point (1,2,3)
- sometimes there is problem to browse on the folders and to select a music : it selects many musics instead of select just one (i also see this bug in mixxx 1.11)
Krosian
 
Posts: 6
Joined: Sat Feb 21, 2015 9:09 am

Re: 1.12.0 Alpha Win (XP,Vista,7,8) / Mac / Linux Testers Ne

Postby Dadj » Sun Mar 01, 2015 10:56 pm

Nothing is working on Lubuntu 15.04 for 1.12 neither ppa or deb files :(

It's telling me that there's a problem with the libprotobuf-lite8 when trying to install the deb by gdebi and when I try to install it via terminal it says that I already have the libprotobuf-lite9... :roll:
Dadj
 
Posts: 40
Joined: Sat Jul 09, 2011 11:46 pm

Keyboard mappings

Postby searchie » Sat Mar 07, 2015 4:31 pm

OS - Ubuntu 14.04 LTS (64-bit)
Processor - Intel Celeron N2480 @2.16GHz x 2
Memory - 3.8GB
Graphics - Intel Bay Trail
Disc 100GB
External Sound card ESI Maya 44 USB
(Toshiba Satellite Part No.PSCMLU-03X09J)

Installed via ppa with no problems. Configured Mixxx to use the external sound card outputs 1 and 2 for Deck 1 and outputs 3 and 4 for Deck 2. The laptop's internal sound card was tried as headphone/cue and master. Everything works fine in that department. So far, no gltches except for when I was trying to select invalid sound devices. I'm not sure how it all works so I don't know if a quick pre check could be done when selecting a device to make sure it is valid before wasting time trying to connect to it. This is not a new issue for me nor is it a big deal since I was experimenting rather than trying to actually set up a device.

The main issue that made me make this post is that I don't seem to be able to activate keyboard mappings. edit: I think I screwed up. I did not notice the "Enable Keyboard Shrtcuts" under the "Option" menu. If it was there before I updated to build 5275 from 5270 then all I can suggest is that the manual state the obvious, something like "To enable keyboard shortcuts, check the 'Enable Keyboard Shortcuts' item under the options menu." /edit Based on the manual, I did not find the cfg file at /usr/local/share/mixxx/keyboard/en_US.kbd.cfg but, did find it at /usr/share/mixxx/keyboard/en_US.kbd.cfg. I tried copying the one I found to the location specified in the manual and copying the one I found to /home/user/.mixxx/Custom.kbd.cfg. Is there something I am missing? I looked through the preferances wiindow and could not find anything.(see edit above)
searchie
 
Posts: 5
Joined: Sun Jun 05, 2011 12:52 am

Re: 1.12.0 Alpha Win (XP,Vista,7,8) / Mac / Linux Testers Ne

Postby turntables » Sat Mar 14, 2015 2:34 pm

I'm going to be upgrading to windows 8 next week so hopefully there won't be any issues, but i will report any probs i get.
turntables
 
Posts: 14
Joined: Thu Mar 12, 2015 4:11 pm

Re: 1.12.0 Alpha Win (XP,Vista,7,8) / Mac / Linux Testers Ne

Postby mnmlguy » Sun Mar 15, 2015 3:56 pm

Hey guys! Is it possible for you to add builds for Ubuntu 15.04 (Vivid Vervet) to PPA?

W: Failed to fetch http://ppa.launchpad.net/mixxx/nightlie ... 4/Packages 404 Not Found
W: Failed to fetch http://ppa.launchpad.net/mixxx/nightlie ... 6/Packages 404 Not Found

Thanks :)
mnmlguy
 
Posts: 6
Joined: Sun Mar 15, 2015 3:51 pm

Re: 1.12.0 Alpha Win (XP,Vista,7,8) / Mac / Linux Testers Ne

Postby Boris_Mirheiss » Tue Mar 17, 2015 9:23 am

rryan wrote:
Krosian wrote:Thanks rryan !

But i have Ubuntu 14.10 and this ppa is for Ubuntu 14.04. Is it possible to update the ppa ?


Does the 14.04 deb fail to install?



yes it fails... :(

W:Failed to fetch http://ppa.launchpad.net/mixxx/mixxx/ub ... 6/Packages 404 Not Found
, E:Some index files failed to download. They have been ignored, or old ones used instead.
Boris_Mirheiss
 
Posts: 1
Joined: Tue Mar 17, 2015 9:06 am

Re: 1.12.0 Alpha Win (XP,Vista,7,8) / Mac / Linux Testers Ne

Postby dinix » Wed Mar 18, 2015 5:53 pm

Boris_Mirheiss wrote:
rryan wrote:
Krosian wrote:Thanks rryan !

But i have Ubuntu 14.10 and this ppa is for Ubuntu 14.04. Is it possible to update the ppa ?


Does the 14.04 deb fail to install?



yes it fails... :(

W:Failed to fetch http://ppa.launchpad.net/mixxx/mixxx/ub ... 6/Packages 404 Not Found
, E:Some index files failed to download. They have been ignored, or old ones used instead.



rryan is there a way to allow the samplers to get back the pointer at the beginning one it has been played?
dinix
 
Posts: 16
Joined: Wed Nov 26, 2014 10:55 am

Re: 1.12.0 Alpha Win (XP,Vista,7,8) / Mac / Linux Testers Ne

Postby jus » Wed Mar 18, 2015 6:20 pm

dinix wrote:rryan is there a way to allow the samplers to get back the pointer at the beginning one it has been played?

Right-click on the samplers play-button seeks to the start and then stops (using the start_stop control).

Edit: Just for clarification, there is currently no control or preference option to automatically jump to the beginning. I`m pretty sure the request is already on the bug tracker, as this has been requested numerous times. I`ll add a link if found.
The Mixxx Manual, Wiki and FAQ are the best place to start for documentation and support.
Please report any bugs you find to our Bug Tracker.

Find out how to contribute to Mixxx development.
User avatar
jus
Mixxx Artist
 
Posts: 1009
Joined: Tue Jun 16, 2009 5:52 pm
Location: Berlin

Re: 1.12.0 Alpha Win (XP,Vista,7,8) / Mac / Linux Testers Ne

Postby slaker96 » Fri Mar 20, 2015 2:48 pm

Tested on Macbook 13

Mixxx build version: mixxx-master-git5292
System Info: Interl Core i5 2.5G / 8GB Ram
OSX version: 10.9 Mavericks
OSX 32-bit or 64-bit? 64-bit
Did the installer succeed? Yes
Did it crash on start-up? No
Did it crash after start-up? No
Did MP3 files load and play? Yes
Did M4A/AAC files load and play? No other formats tested
Did Filtered (GL) waveforms work? Yes
Did GLSL waveforms work? Yes
Did Software waveforms work? Yes
Any corruption / glitching? Waveforms seemed pretty smooth once I tuned off tooltips. They also glitch when you scroll in the library or single-click a song title.

Non waveform issues were some songs loading in a higher key, noticebly different pitch.

After some time playing songs, newly loaded songs will not display a waveform until the analyzing is complete.

Audio was pretty stable, application did not crash during the 2 hours of use. Effects works and mixxx did not crash during live skin/waveform changes as well.
slaker96
 
Posts: 114
Joined: Wed Mar 28, 2012 7:00 pm

Re: 1.12.0 Alpha Win (XP,Vista,7,8) / Mac / Linux Testers Ne

Postby shalty » Sun Mar 22, 2015 1:04 pm

Tests on a Dell e6500 laptop (core2duo, intel 4 series express chipset "gpu"), with the lastest alpha (r5300, x86)

First under Windows 10 x64 build 10041:
Works fine, waveforms (opengl) and all. Doesn't show any covert art on the files (when windows does). Totally unusable for HID controllers (for me, at least).

Same hardware, but with Windows 7 sp1 x86:
Crash at first execution because accelerated opengl waveforms. Changing manually to disable/software waveforms works fine. Last driver (2012 :( ) installed and verified (8.15.10.2869, WHQL). Any try to change waveforms from inside the running Mixxx makes it fail at the same code.
Here it shows some cover art, but not for all the files that have it. Alphas from a month ago showed way more covert arts for the same files.
Again, totally unusable for HID controllers.

The HID problem is reported here (https://bugs.launchpad.net/mixxx/+bug/1426925). On the 1.12s the problem is worst than on 1.11, because it seems that increasingly acumulates "commands" (queued emit()'s?) to be executed later, so the time between an action on the controller, and Mixxx responding, is increasingly exponential (we are talking a lot of seconds after a minute running)

The waveform problem on w7 has this stack trace (stack from a february build of mine, has more info and the failure it's the same on both). I don't know how to try to solve it :(

Code: Select all
    
    ig4icd32.dll!112e3fa5()   Unknown
    ig4icd32.dll!112e02eb()   Unknown                          <<<<< intel opengl driver
    [External Code]   
>   QtOpenGLd4.dll!QGLContext::swapBuffers() Line 1344   C++
    QtOpenGLd4.dll!QGLWidget::swapBuffers() Line 4068   C++
    mixxx.exe!WaveformWidgetFactory::swap() Line 493   C++
    QtCored4.dll!QMetaCallEvent::placeMetaCall(QObject * object) Line 524   C++
    QtCored4.dll!QObject::event(QEvent * e) Line 1222   C++
    QtGuid4.dll!QApplicationPrivate::notify_helper(QObject * receiver, QEvent * e) Line 4565   C++
    QtGuid4.dll!QApplication::notify(QObject * receiver, QEvent * e) Line 3947   C++
    mixxx.exe!MixxxApplication::notify(QObject * target, QEvent * event) Line 140   C++
    QtCored4.dll!QCoreApplication::notifyInternal(QObject * receiver, QEvent * event) Line 953   C++
    QtCored4.dll!QCoreApplication::sendEvent(QObject * receiver, QEvent * event) Line 231   C++
    QtCored4.dll!QCoreApplicationPrivate::sendPostedEvents(QObject * receiver, int event_type, QThreadData * data) Line 1577   C++
    QtCored4.dll!qt_internal_proc(HWND__ * hwnd, unsigned int message, unsigned int wp, long lp) Line 496   C++
    [External Code]   
    QtCored4.dll!QEventDispatcherWin32::processEvents(QFlags<enum QEventLoop::ProcessEventsFlag> flags) Line 823   C++
    QtGuid4.dll!QGuiEventDispatcherWin32::processEvents(QFlags<enum QEventLoop::ProcessEventsFlag> flags) Line 1212   C++
    QtCored4.dll!QEventLoop::processEvents(QFlags<enum QEventLoop::ProcessEventsFlag> flags) Line 150   C++
    QtCored4.dll!QEventLoop::exec(QFlags<enum QEventLoop::ProcessEventsFlag> flags) Line 204   C++
    QtCored4.dll!QCoreApplication::exec() Line 1225   C++
    QtGuid4.dll!QApplication::exec() Line 3824   C++
    mixxx.exe!main(int argc, char * * argv) Line 350   C++
shalty
 
Posts: 110
Joined: Sat May 12, 2012 11:44 am

PreviousNext

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 3 guests