MIXX to Shoutcast trouble

General Mixxx discussion.... discuss

Moderator: garth

MIXX to Shoutcast trouble

Postby rickyspires » Tue Apr 17, 2018 10:29 pm

Hello.

I am trying to get shoutcast to connect to Mixx dj software but i can not get it to work.

I have watched tutorials but no luck.

My shoutcast setting ...

Your streaming server URL is "master.shoutcast.com".
Your port is "8000".
Your Stream ID is "1******9".
http://listen.shoutcast.com/phonolive


on mixx the setting are:

Live broadcast:
type: Shoutcast1
Host: master.shoutcast.com
Login: I left this blank
Mount: I left this blank
Port: 8000
Password: I created one to use.

note i also tried my password with the id like this.... pw:#1******9

When I play the music in mixx and choose "live stream" and go to http://listen.shoutcast.com/phonolive i get the following: The file you requested could not be found .

https://www.mixxx.org/
http://www.shoutcast.com/

There is also a popup window with the following:

One of the Live Broadcasting connections raised this error:
Error with connection 'Connection 1':
Can't connect to streaming server

Socket is busy
Please check your connection to the internet and verify that your username and password and correct.


I am trying to do a dj live radio stream to my wordpress site.

any help would be great . thanks.

Ricky
rickyspires
 
Posts: 2
Joined: Tue Apr 17, 2018 10:27 pm

Re: MIXX to Shoutcast trouble

Postby JosepMa » Wed Apr 18, 2018 8:51 pm

Yes, you probably need the password in the pw:#1****9 format.
Also, not sure if you have done so, but the field "Stream name" cannot be empty.

You might need to check the mixxx.log file more more information about the problem of not being able to broadcast.
Please, locate it and upload it here as an attachment when replying (Note: Each time you open Mixxx, a new file is created and the older ones get renamed in an ordered way .1 newer than .2 etc..)

The log is placed in:

Windows (type it into the file explorer to open it)
%LOCALAPPDATA%\Mixxx\
(If you upgraded from Mixxx 1.11 at some point, it might be this instead: %USERPROFILE%\Local Settings\Application Data\Mixxx\ )

macOS
~/Library/Application Support/Mixxx

GNU/Linux
~/.mixxx
JosepMa
 
Posts: 888
Joined: Sat Oct 10, 2015 7:02 pm

Re: MIXX to Shoutcast trouble

Postby rickyspires » Mon Jul 16, 2018 6:05 am

Hello.

Sorry for the late reply. Thank you for your help.

I am almost there. Mixx is connecting :)

Thanks

Ricky
rickyspires
 
Posts: 2
Joined: Tue Apr 17, 2018 10:27 pm

Re: MIXX to Shoutcast trouble

Postby Lakepantim » Sat Sep 15, 2018 4:01 pm

Hi Rick,

I'm having the same issues with Mixxx. How did you get it to connect?

Thanks,
Tim
Lakepantim
 
Posts: 1
Joined: Sat Sep 15, 2018 3:59 pm

Re: MIXX to Shoutcast trouble

Postby djSpeedy » Sun Sep 30, 2018 9:29 pm

Problem is that you forgot to set the login, which is 'admin', assuming you're using SHOUTcast v1.9.3.

Here's a screenshot from my config :)
► If it isn’t broken, shouldn't we fix it until it is? ◄
User avatar
djSpeedy
 
Posts: 1
Joined: Sun Sep 30, 2018 9:11 pm

Re: MIXX to Shoutcast trouble

Postby morlanius » Sun Jun 14, 2020 1:16 am

Hi,
I know this is an old post but I had a very similar issue to this and this post was closest to the problem I'm having and no one seemed to have the solution.
Here is what I found!

The shoutcast server has an option that says that you have to have a config set, you might be thinking its your audio settings, bitrate or something like that but no. In broadcast settings make sure you set a stream name, description and put a URL in the URL field even if you deselect "enable public broadcast" you need to have that data in there it it will say "socket error" and the server will keep bouncing you.

Hope this helps someone.


~Morl
morlanius
 
Posts: 1
Joined: Sun Jun 14, 2020 1:10 am


Return to General Discussion

Who is online

Users browsing this forum: Google [Bot] and 11 guests